Tools
Unable to connect through SFTP using Java-based clients after upgrading to Serv-U version 15.3.2 and up
This article shows how to troubleshoot issues with connecting through Serv-U SFTP using Java-based clients
First published date
Last published date
Overview
We are seeing SFTP login failures after upgrading starting on Serv-U version 15.3.2:
Clients connecting using automated jobs, the Cisco app, or any Java-based application can no longer connect and transfer files through SFTP.
Our Developers are aware of this issue and have provided a hotfix for Serv-U 15.3.2 or upgrade to the latest version that ignores RFC compliance.
Reported clients that are affected
- JSCH
- Maverick Legacy Client
- Cisco Unified Backup
Product section
Cause
Resolution
Resolution Options:
1. Upgrade to the latest version which allows ignoring RFC compliance. The installer can be obtained through the Customer Portal. After the upgrade, follow the instructions below to enable or disable non-RFC-compliant connections:SFTP connection not established for legacy Java clients
2. Reach out to your application team to add a CR symbol in your Java-Based client code and ensure that the program is RFC compliant.
The Java client used doesn't follow protocol version exchange correctly.
RFC ft-ietf-secsh-transport: The Secure Shell (SSH) Transport Layer Protocol The identification MUST be terminated by a single Carriage Return (CR) and a single Line Feed (LF) character 2 (ASCII 13 and 10, respectively). The client identification string SSH-2.0-JSCH-0.1.54 does not contain CR symbol, which is mandatory according to RFC.
4. Roll back to the previous version of Serv-U either by reverting to your Serv-U server snapshot backup or following this article.