Tools

Dameware Mini Remote Control: Unable to Start/Stop or Install/Remove Agent Service with "RPC server is unavailable," "Winsock Connect Error: 10060," or "Logon Failure. System Error: 64"

This article describes Dameware Mini Remote Control errors "The RPC server is unavailable," "Winsock Connect Error: System Error: 10060," and "Logon Failure. System Error: 64." when the user cannot stop/start or install/remove a Dameware Agent service from the DMRC client to the remote machine.

First published date

7/10/2026 9:32 AM

Last published date

7/10/2026 9:32 AM

Overview

Dameware Remote Control needs access to remote files to call or copy the resources required to manage the Dameware Mini Remote Control Service across the network. Without these required ports and services, Dameware may fail to Start/Stop or Install/Remove Agent Service remotely.

The following error appears when trying to Start/Install the Dameware Agent Service:

Dameware Mini Remote Control - Error - X.X.X.X
Winsock Connect Error: System Error: 10060 System Message:
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Host: X.X.X.X

MRC-Enter Dameware Mini Remote Control - Logon
Incorrect X.X.X.X
Logon Failure. System Error: 64
System Message:
The specified network name is no longer available.

The following error appears when trying to Stop/Remove the Dameware Agent Service:

Dameware Mini Remote Control - Service X
Unable to stop Service System Error: 1722
System Message:
The RPC server is unavailable.

This article is applicable only for an environment where there is no issue with the Account Use for authentication in Dameware, and the port required for Dameware is already open across the internal network.
If the Dameware has been confirmed not to be working since its implementation, it might not be related to this one.
Please contact SolarWinds Technical Support for issue during initial implementation.

Product section

Dameware Remote Support & Mini Remote Control

Cause

Missing Windows requirements.

Resolution

  • Make sure all Ports Required for Dameware are open between the DMRC client and DMRC agent, especially the following ports:
    • Dameware Port 6132 
    • Remote Procedure Call (RPC) / RPC Endpoint Mapper: TCP 135
    • SMB / Named Pipes / File and Printer Sharing: TCP 445, 
  • The following must be configured  for the DMRC client and all DMRC agents:
    1. Go to the Control Panel > Network and Sharing Center.
    2. In the left pane, click Change advanced sharing settings.
    3. Under Domain (current profile), select Turn on file and printer sharing.
    4. Save your changes.
    5. Close and relaunch DMRC.