Tools

Web Help Desk is down with an email data object error

This article addresses an issue that prevents Web Help Desk from starting and displays an error message in the TRUNCATE EMAIL_DATA_OBJECT file.

First published date

10/18/2018 1:11 PM

Last published date

6/23/2026 8:16 PM

Overview

This article describes how to resolve the issue where WHD is down and TRUNCATE EMAIL_DATA_OBJECT gives the following error message:

 The transaction log for database 'WHD' is full due to 'LOG_BACKUP'

Product section

Web Help Desk

Cause

This issue occurs when the EMAIL_DATA_OBJECT size increases exponentially. This object stores reference data, such as rejected email. 

Resolution

Address the database issue 

  1. Change Database Recovery model from Full to Simple.
  2. Shrink log files using SQL Studio.
    1. Right click WHD Database and select Tasks > Shrink > Files.
    2. Select the Log in File Type field.
    3. Click OK.
  3. Run the SQL query, TRUNCATE TABLE EMAIL_DATA_OBJECT

Control the growth of EMAIL_DATA_OBJECT 

  1. Log in to the WHD Console as an Administrator.
  2. Go to Setup > E-Mail > Options.
  3. Under E-Mail Options, set the Delete E-Mail History Entries After setting to a shorter time period.
     
  4. Click Save.