Tools

The Simple File Transfer (SFT) shell menu may not be available in Dameware

Information regarding the Simple File Transfer (SFT) shell menu in Dameware and why it may not be available.

First published date

10/7/2018 10:42 PM

Last published date

7/28/2020 8:17 PM

Overview

If you receive the following informational message in Dameware, it means that the Dameware Mini Remote Control (DMRC) software cannot detect if the operating system has properly registered the DMRC Simple File Transfer (SFT) Explorer Shell menu:

The Simple File Transfer (SFT) Shell Menu may not be available.

What is the SFT shell menu?

Using the SFT shell menu, you can right-click a file or folder and select Dameware MRCS/Copy to Remote Host to transfer these files/folders to the remote machine. 


 

Product section

Dameware Remote Support & Mini Remote Control

Resolution

The process of loading or unloading the SFT shell menu is handled directly by the operating system. Even if you receive the informational message about SFT shell menu not being available, it does not mean that you cannot transfer files from the local to the remote machine.

Other ways to transfer files 

To transfer from the local machine to the remote machine, drag the files or folders directly into the active DMRC window. The files will automatically be copied to the remote machine's SFT folder defined within the DMRC Client Agent Service on that remote machine (click the Remote Upload Folder toolbar button after completion).

In version 9.x and later versions, Dameware development added a new SFT drop window feature on the remote machine. To open it, either select the SFT > Open Remote Drop Window menu option from the DMRC main menu or hold down the Shift key and click the Open the Remote Upload Folder toolbar button in the DMRC toolbar. This feature was added to allow a user to drag and drop files from the remote machine directly to the SFT drop window then back to the local machine when the SFT shell menus are not available.

Hide the message 

In Dameware 9.x and later versions, you can disable the message display:
  1. Open the DMRC software and press ESC when the Remote Connect dialog is displayed. 
  2. Select View > Local Global Options from the DMRC main menu (or click the Local Global Options toolbar button).  
  3. Select the General Options tab.
  4. Disable the Check SFT shell menu option.