Applications Systems

Real-time tools fail with "Index was outside the bounds of the array" when using gMSA credentials in SAM

If Real-Time Process Explorer, Service Control Manager, or Real-Time Event Log Viewer fail with Index was outside the bounds of the array on a Windows node that uses a gMSA credential, the issue can be caused by the way the gMSA username is stored rather than by WinRM, Kerberos, or WMI connectivity.

First published date

7/7/2026 6:36 PM

Last published date

7/7/2026 6:59 PM

Overview

After upgrading Server & Application Monitor, real-time tools can fail on Windows nodes that use gMSA credentials when the gMSA username is saved in UPN format such as account$@domain or as a bare account name such as account$. In this condition, Real-Time Process Explorer, Service Control Manager, and Real-Time Event Log Viewer may return Index was outside the bounds of the array.

Product section

Server Application Monitor

Cause

This issue occurs when the gMSA username is stored in a format that the real-time tools cannot parse correctly. The tools require the gMSA username to be entered in down-level format with a backslash.

Resolution

Update the gMSA credential so the username is stored in down-level format with a backslash, then reopen the real-time tool.

Example:

  • Change MyGMSA1$@test.local to test.local\MyGMSA1$.