Tools
"User failed to be updated or created: undefined" error in Kiwi Syslog NG when creating a user without SMTP
This article describes the resolution when encountering an issue with creating an additional user/admin in Kiwi NG.
First published date
Last published date
Overview
This error appears: "User failed to be updated or created: undefined" when creating user/admin.
Product section
Cause
The verbose logging doesn't get logged, if the server doesn't have SMTP server configured.
This is a known issue in Kiwi Syslog NG 1.4.
Resolution
Activating the user without SMTP is possible using the mail debug logs option. However, due to a known issue in Kiwi NG, this will be unsuccessful. In the meantime, SMTP is required as a workaround.
Workaround - local SMTP server (preferred)
- Download: https://github.com/ChangemakerStudios/Papercut-SMTP/releases/download/7.0.1/PapercutSMTP-win-x64-stable-Portable.zip
- Open the portable PapercutSMTP app.
- From Syslog NG, leave the SMTP settings to 127.0.0.1 as SMTP server
- Create a new user or admin in Syslog NG
- From PapercutSMTP, you should receive the new user invitation email. Check the BODY tab and look for an Accept invitation link, it should look like this below: line-height: 25px;" href="https://192.168.1.131:5000/login/reset?code=8bdc5f38-9008-40b3-b532-57fbfbc6f5b7">Accept invitation</a>
- Copy and open the link from your browser and this should let you confirm a password for the newly created user.
Scenario 2: SMTP is already set and successfully sends email via PowerShell, but is still getting a similar error.
- Check the logs. If you noticed a similar error below:
It means that there is no SMTP AUTH in that session invitation. The mail server requires authentication, and authenticated sends work, but KSS NG is currently trying to send without credentials and is blocked with 554 Access denied.
Resolution:
1. Please check if they have the same account in the NG console > Setup > Settings > MAIL > SMTP. If yes, please test and ensure the result is successful.
2. If it fails, allow anonymous relay from the KSS NG server on the SMTP side.
3. Once the 554 error is gone, request to resend the user creation/invitation in Kiwi Syslog NG, and it will succeed.