Network Management

"Failed to retrieve access token, please check the credentials provided" Error while adding Ruckus One Orchestrator devices via API Polling

This article helps when users face issues while adding Ruckus One wireless infrastructure to NPM using the Orchestrators: API polling method.

First published date

7/10/2026 3:34 PM

Last published date

7/10/2026 3:34 PM

Overview

When adding Ruckus One wireless infrastructure to NPM via API polling using the Orchestrators, the region can auto-fill a base URL that returns an HTTP 404 error during connectivity tests, preventing the orchestrator from being added and monitored with the error "Failed to retrieve access token, please check the credentials provided."

 

Product section

Orion Platform

Cause

In some deployments, the Advanced Configuration for Ruckus One uses an outdated base URL for the region:

Example: Europe

Ruckus One now expects the following region endpoints instead:

Since the platform still points to the Europe region to https://api.europe.ruckus.cloud, connectivity tests to that URL fail with HTTP 404: Not Found until the base URL is corrected to https://api.eu.ruckus.cloud in Advanced Configuration.

Resolution

  1. Log in to the SolarWinds Platform Web Console using an account with administrative privileges.
  2. Access the Advanced Configuration settings in the SolarWinds Platform Web Console 
  3. Ctrl + F and paste the URL https://api.europe.ruckus.cloud in the search box, and it will directly take you to the URL section.
  4. Edit and paste the URL for what you are looking for, then save. 

Come back to manage nodes, add the node to Ruckus One, and select the base URL; it will change.

Image_2025-10-10_21-06-35.png 

Note: 

  • Use the following Ruckus One region endpoints as a reference when validating configuration: 

For additional information about Ruckus in NPM, please refer to the following admin guide. RUCKUS One