Tools
ETS Error: Cannot Start TFTP Server. A TFTP Server is running on port 69
This article provides brief information describing possible causes and steps to resolve the following error: Cannot start TFTP Server. A TFTP Server is running on port 69. ETS. Engineer's Toolset.
First published date
Last published date
Overview
This article provides brief information describing possible causes and steps to resolve the following error:
Cannot start TFTP Server. A TFTP Server is running on port 69.
Product section
Cause
Any of the following causes the error:
- An instance of TFTP Server is already running.
- Another program is using port 69.
- ETS and Cirrus running on the same computer - ETS and Cirrus contain different versions of the TFTP Server. A conflict can occur because the Cirrus TFTP Server is a self-contained program, but the ETS TFTP Server runs as a Windows service. Cirrus is fully compatible with the ETS TFTP Server service and uses that version of TFTP Server, but you cannot run the Cirrus version of TFTP Server if the ETS version is already running.
- A proxy is blocking port 69 - If the "netstat - a" test reveals that port 69/TFTP is only in use when the Cannot Start TFTP Server. A TFTP Server is running on port 69 message appears, then it is likely that a proxy server on your network is blocking port 69.
Resolution
- An instance of TFTP Server is already running
If your system tray contains an icon that depicts two desktop computers, this indicates that you are already running TFTP Server. Double-click the icon in the system tray to open the already running TFTP Server.
- Another program is using port 69 - Do the following to find out if another program is using port 69:
1.Open Command Prompt.
2. Enter
netstat -a
3. Identify any items under the Local Address column that include:69 or :tftp.
4. If another program is using port 69, you need to close that program before you can run TFTP Server.
- ETS and Cirrus running on the same computer
Cirrus is fully compatible with the ETS TFTP Server service and uses that version of TFTP Server, but you cannot run the Cirrus version of TFTP Server if the ETS version is already running.
- A proxy is blocking port 69
Consult your network administrator for assistance.