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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Unable to connect to clients using WMI

Unable to connect to clients using WMI

Updated June 20, 2018

Overview

When you try to connect to your client systems using WMI, you are unable to connect.

To resolve this issue, try installing an agent using the Remote Installer Service with a WSUS package. 

Environment

  • All Patch Manager versions

Cause 

Environmental restrictions

Resolution

  1. Log in to the Patch Manager Administrator Console as an administrator.
  2. In the navigation pane, expand Enterprise.
  3. In Managed Computers or Update Services > WSUS > Computers and Groups > All Computers, locate and select the computer that requires an agent.
  4. In the Actions pane, click Deploy Client Components.
  5. Select Install or Repair Client Components, and click Next.
  6. Select an option:
    • Install WMI Providers
    • Install the Patch Manager Agent
  7. Select an option:
    • Install using Remote Install Service
    • Create a WSUS Installer Package.
  8. Complete the wizard based on your selection. See the appropriate section below.  

Install using Remote Installer Services

If you choose Remote Installer Services, the wizard launches a task to install the agent with Patch Manager. Complete the steps in the task.

Create a WSUS Installer Package

If you choose WSUS Package:

  1. Expand Administration and Reporting > Software Publishing and select SolarWinds Inc. Packages.
  2. In the center pane, locate and select the SolarWinds Patch Manager Agent package.
  3. Publish that package to your WSUS.
    After you publish the package, you can approve it for your groups.

 

 

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