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Home > Success Center > ipMonitor > ipMonitor - Knowledgebase Articles > Credentials sensitive data hive error in ipMonitor

Credentials sensitive data hive error in ipMonitor

Updated September 21, 2018

Overview

When you are running ipMonitor, the following error displays:

The credentials sensitive data hive is currently unavailable.

Environment

  • ipMonitor 9

Cause

Broken credentials are commonly caused by the following:

Details

Repair credentials broken by account permission changes

Credentials break if the account permissions related to the encryption container are no longer working. As a result, the Credentials Data Hive cannot be decrypted. This can happen if user accounts are changed through the Services MMC Snap-in, located within Windows Control Panel > Administrative Tools, instead of through the ipMonitor configuration program. The configuration program adjusts account permissions as needed, but the Services snap-in does not.

To fix credentials broken by changing Windows account permissions:

  1. Stop the ipMonitor Service
    1. Open a Run box.
    2. In the box, enter the following and click OK:
      net stop ipmonitorsrv
  2. Launch the ipMonitor configuration program.
  3. Click Service Settings.
  4. Change Log On Account to an account that is neither the LocalSystem account or the desired account, and then click Apply.
  5. Change the Log On Account to the desired account (again, not LocalSystem), and then click Apply.
  6. Restart the ipMonitor Service.
    1. Open a Run box.
    2. In the box, enter the following and click OK:
      net start ipmonitorsrv

Repair credentials broken by moving the credentials database to another computer

Credentials break if the credentials database was moved from one computer to another. This causes the database to stop working because the database is locked to the original computer.

To fix credentials broken by moving the credentials database:

  1. Stop the ipMonitor Service.
    1. Open a Run box.
    2. In the box, enter the following and click OK:
      net stop ipmonitorsrv
  2. Navigate to the following directory:
    \ipMonitor\config\cred\
  3. In the directory, delete the existing database file:
    credentials.db
  4. Run the ipMonitor configuration program in first run mode.
    1. Open a Run box.
    2. In the box, enter the following and click OK:
       C:\Program Files\SolarWinds\ipMonitor\ipm9config -firstrun
  5. Restart the ipMonitor Service.
    1. Open a Run box.
    2. In the box, enter the following and click OK:
      net start ipmonitorsrv

Restore or reinitialize the existing credentials

If you have an internal backup created by ipMonitor's internal maintenance schedule, restore the Credentials information using the ipMonitor 9 Restore Utility (ipm9restore.exe), located the C:\Program Files\SolarWinds\ipMonitor directory. If you do not have an internal backup, reinitialize the existing credentials.

  1. Log in to the ipMonitor web interface.
  2. Click the Configuration tab.
  3. Click Credentials List.
  4. Perform the following steps for each credential in the list:
    1. Click the credential name to view its settings.
    2. On the menu bar, click Reinitialize.
  5. In the Sensitive Data section, click the Enable buttons, and then re-enter the account and password.
  6. Click OK.
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