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Home > Success Center > ipMonitor > ipMonitor - Knowledgebase Articles > Credentials are not functioning with the assigned monitors and alerts

Credentials are not functioning with the assigned monitors and alerts

Updated September 21, 2018

Overview

The credentials are not functioning with their assigned monitors and alerts. When you access the Credentials Manager, the following message is displayed:

Warning: The Credentials Sensitive Data hive is currently unavailable. 

Environment

  • ipMonitor 8

Cause

  • The Account Permissions related to the encryption container are no longer working. As a result, the Credentials Data Hive cannot be decrypted. This can occur when user accounts have been changed via the Services MMC Snap-in, located within Windows Control Panel > Administrative Tools, rather than through the ipMonitor Configuration Program. The Configuration Program will adjust Account Permissions as needed, while the Services Snap-in will not.
  • The Credentials Database was recently moved from one machine to another. The Credentials Database is designed to be bound to the machine on which it was created.

Resolution

Repair the account permissions

  1. Stop the ipMonitor Service.
    1. Open a Run box
    2. Execute the following command:
      net stop ipmonitor
  2. Launch the ipMonitor Configuration program.
  3. Click Service Settings.
  4. Set the Log On Account to a NON-LocalSystem Account, and click Apply.
  5. Switch the Account back to the desired NON-LocalSystem Account, and click Apply.
  6. Restart the ipMonitor Service.
    1. Open a Run box.
    2. Execute the following command:
      net start ipmonitor8

Recover a migrated credentials database

  1. Stop the ipMonitor Service.
    1. Open a Run box
    2. Execute the following command:
      net stop ipmonitor
  2. Move the following file either to the desktop or to another location:
    \ipMonitor\config\cred\credentials.db
  3. Restart the ipMonitor Service.
    1. Open a Run box.
    2. Execute the following command:
      net start ipmonitor8
  4. If an internal backup created through the use of ipMonitor's Internal Maintenance Schedule is available, restore the Credentials information using the Backup-Restore Utility located in the installation folder.

Reinitialize the existing credentials

If an internal backup does not exist, reinitialize the existing credentials.

  1. Log in to the ipMonitor Administration Web Interface.

  2. Click Security and select Credentials Manager.
  3. Perform the following steps for each credential.
    1. Click the credential name to view its settings.
    2. Click Reinitialize located on the second row of the top navigation menu.
    3. In the Sensitive Data section, click Enable to re-enter the username and password.
    4. Click OK to save your changes.
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