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Home > Success Center > ipMonitor > ipMonitor - Knowledgebase Articles > Alert and report email recipients do not receive email messages from ipMonitor

Alert and report email recipients do not receive email messages from ipMonitor

Updated September 20, 2018

Overview

Email recipients are not receiving emails from ipMonitor.

Environment

ipMonitor

Cause

Email delivery may fail for several reasons, especially in a modern corporate environment containing spam filters and firewalls. ipMonitor administrators can configure all related settings in order to ensure that emailed Alerts and Reports are sent appropriately.

ipMonitor attempts to deliver email using the following procedure

  1. ipMonitor attempts to connect to domain.com 25 where domain.com is the email recipient's domain, and 25 is the port.
    If the connection is successful, the email message is sent to the recipients.
    If the connection is not successful, ipMonitor connects to the DNS server to look up the preferred MX record for the recipient's domain.
  2. ipMonitor attempts to connect to the MX record on port 25.
    If the MX record connection is successful, the email message is sent to the recipients.
    If the MX record connection is not successful, ipMonitor attempts to connect to the next listed MX record (if available). Otherwise, the email cannot be sent to the recipients. 

Resolution

To bypass this trial-and-error email delivery process, specify an SMTP mail server for ipMonitor to use. If your specified mail server is unreachable, ipMonitor reverts to using the trial-and-error steps outlined above.

To specify an SMTP mail server for ipMonitor: 

  1. Log in to the ipMonitor web console.
  2. Click the Configuration tab and then click System Settings.
  3. Next to SMTP relay server, click Enable.
  4. Enter the IP address and TCP Port of your SMTP mail server in the appropriate fields.
  5. If your SMTP mail server does not require authentication, you are finished.
    If your SMTP mail server requires authentication, click Select to create or select credentials for SMTP authentication.
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