Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Web Performance Monitor (WPM) > Webpage only showing blank screen

Webpage only showing blank screen

Created by Roger Lofamia, last modified by Rodim Suarez on Mar 07, 2017

Views: 53 Votes: 0 Revisions: 5

Updated March 7, 2017

Overview

Attempting to open a website on WPM Recorder and it only shows a blank or empty screen or it seems that the website is not able to load and is only showing the background.

 

The website opens and shows as normal when opened on an Internet Explorer browser:

Environment

WPM 2.2.1

Cause 

It is identified that the issue is on how WPM recorder web browser process the web page. The webpage contains standards-based !DOCTYPE directives which can only be displayed on IE in edge mode. WPM recorder is not compatible on this mode.
The workaround solution that we have will change how WPM recorder process the webpage containing standards-based !DOCTYPE directives.

Resolution

  1. Open regedit on the machine where WPM Recorder is installed.
  2. Navigate to HKLM\SOFWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\Feature_Browser_EMULATION.
  3. Change value for SolarWinds.SEUM.Recorder.exe to 10001.
  4. Start WPM Recorder and the content should load on the page.

See Internet Feature Controls (B..C) for more information.

NOTE: Now important thing. After you create recording, successful playback from Orion will require same change in reg value for SolarWinds.SEUM.Agent.Worker.exe in same path as in 2. (Is present on every playback location, so if machine where Recorder is installed does not also serve as playback location, then this value reg file will not be present there). Inform customer that this change will force whole transactions on that location to use this emulation. This should not cause any issue, but customer should know. If his env is big, I would suggest you to first create some test playback location, change value SolarWinds.SEUM.Agent.Worker.exe to 10001 and then verify that transaction is up. 

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

 

Last modified
21:02, 6 Mar 2017

Tags

Classifications

Public