Submit a ticketCall us

Announcing NPM 12.2
With NPM 12.2 you can monitor your Cisco ASA firewalls, to monitor VPN tunnels for basic visibility and troubleshooting tunnels. NPM 12.2 also uses the SolarWinds Orion Installer so you can easily install and upgrade one or more Orion Platform products simultaneously.
See new features and improvements.

Home > Success Center > Web Performance Monitor (WPM) > Unable to upgrade main polling engine due to an installed MIB v1.0.4

Unable to upgrade main polling engine due to an installed MIB v1.0.4

Updated March 13, 2017

Overview

This article will provide a resolution and some troubleshooting steps on the issue where WPM 2.2.0 fails to install because it is detecting that MIB v1.0.4 is already installed.

 

Environment

WPM 2.2.0 upgrading to WPM 2.2.1

Cause 

There is already a MIB application with v1.0.4 already installed on the main poller (Orion WPM server). This will cause conflict with the WPM installer and will result to a failed upgrade installation.

Resolution

  1. Check on the Orion WPM server (main poller) the MIB registy key if the MIB v.1.0.4 is included. Check as well if there are other MIB versions installed.
    As you can see on the screenshot. Only version 1.0.17 is registered on the MIB registry key.
  2. After you verify that only MIB 1.0.17 is installed, check the installed programs on the server if MIB 1.0.4 is installed. If its installed, you can safely uninstall it since its not actually a registered application on the Orion MIB registry.
  3. After uninstalling MIB 1.0.4, run the WPM 2.2.1 installer package again. This time it should allow the upgrade to install successfully. If in case it still failed with the same error. Kindly generate a diagnostic log and contact SolarWinds Technical Support Team for further assistance.

 

Last modified
23:40, 12 Mar 2017

Tags

Classifications

Public