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Home > Success Center > Web Performance Monitor (WPM) > WPM - Knowledgebase Articles > Unable to assign transaction monitor to player

Unable to assign transaction monitor to player

Updated: August 4, 2016

Overview

This article describes the issue when you are unable to assign saved transaction to WPM player and you get this log error:

2016-08-02 15:19:49,246 [PlaybackDispatcher] ERROR SolarWinds.SEUM.Agent.WorkerProcessManagement.WorkerProcessManager - Unable to create worker process. Trying again.
SolarWinds.SEUM.Agent.Exceptions.AgentException: Error connecting to worker process 74012f54-e7c2-43c1-86d1-c46716235cae. Unable to connect to worker after 30000.
   at SolarWinds.SEUM.Agent.WorkerProcessManagement.WorkerProcessWCFProxy.Connect(Boolean launchProcess)
   at SolarWinds.SEUM.Agent.WorkerProcessManagement.WorkerProcessWCFProxy..ctor(String userName, String domain, String password, Int32 sessionId)
   at SolarWinds.SEUM.Agent.WorkerProcessManagement.WorkerProcessFactory.CreateWorkerProcess(String username, String domainOrMachine, String password, Int32 sessionId)
   at SolarWinds.SEUM.Agent.WorkerProcessManagement.WorkerProcessManager.AddWorkerProcess(String username, String domainOrMachine, String password, Boolean runInInteractiveSession)

Environment

All versions of WPM

 

Cause 

This is due to seum-userxxx permission.

Resolution

The Domain policy forbids non-administrator local accounts to log into the computer with the SEUM player. To fix this:

  1. Modify the SEUM user account that is experiencing this issue to be a local admin (add to local administrators group). 
  2. Navigate to Control Panel > User Accounts > Manage User Accounts.
  3. Select SEUM User > Properties > Group Membership.

 

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