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Home > Success Center > Web Help Desk (WHD) > Web Help Desk survey link does not redirect to HTTPS

Web Help Desk survey link does not redirect to HTTPS

Updated July 12, 2018

Overview

The Web Help Desk survey does not redirect to HTTPS.

Environment

  • Web Help Desk 12.5.2 and below

Cause 

HTTPS or Redirect to HTTPS is not configured properly.

Resolution

Edit the whd.conf file and modify the port parameters.

  1. Log in to the Web Help Desk Administrator Console as an administrator.
  2. Go to Setup > General > Options.
  3. Select the Force to HTTPS checkbox, and click Save.
  4. Under General, select Server Options.
  5. Make sure the following server options are enabled, and click Save:
    • HTTP
    • HTTPS
    • Redirect HTTP Requests to HTTPS
  6. Log in to the Web Help Desk server.
  7. Navigate to your Web Help Desk home directory.

    Apple® OS X:  /Library/WebHelpDesk  

    Microsoft® Windows®:   \Program Files\WebHelpDesk  

    Red Hat®/CentOS™ /Fedora Linux: /usr/local/webhelpdesk

  8. Open the /conf directory.
  9. Open the whd.conf file in a text editor (such as Notepad).
  10. Locate the PORTS section in the file. 
  11. In the file, make the following changes: 
    ======================
    # PORTS
    
      DEFAULT_PORT=8081
      HTTPS_PORT=8443
    
    (Note: Set the correct port that you are using.)
    ======================
    
    # NO REDIRECT TO HTTPS
        
      #NO_REDIRECT=true
    ======================
    
  12. Save the file.
  13. Restart the Web Help Desk services.

 

 

 

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