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Home > Success Center > Web Help Desk (WHD) > Web Help Desk generates an error message after an upgrade

Web Help Desk generates an error message after an upgrade

Overview

After you initiate a Web Help Desk upgrade from a remote system and log in to the application, the following message displays: 

An update to the help desk is in progress.

Please come back in a few minutes.

Environment

All Web Help Desk versions

Cause 

The upgrade must be completed from the Web Help Desk Admin Console installed on the Web Help Desk server.

Resolution

Complete the upgrade from the Web Help Desk console.

  1. Log in to the Web Help Desk Admin Console as an administrator.
    A message displays, prompting you to complete the upgrade.
  2. Click OK to complete the upgrade.

Update the whd.conf file 

To avoid this issue during the next upgrade, update the whd.conf file in your Web Help Desk home directory to allow the server to log in to the Web Help Desk Admin Console automatically and complete the upgrade.

SolarWinds strongly recommends that you edit the whd.conf file only as instructed. Any additional modifications may result in system performance issues or may create an error state.

  1. Log in to the Web Help Desk server as an administrator.
  2. Stop Web Help Desk.
  3. Navigate to your Web Help Desk home directory.
    •  Apple OSX: /Library/WebHelpDesk
    • Microsoft Windows: \Program Files\WebHelpDesk
    • Linux: /user/local/webhelpdesk
  4. In the home directory, open the conf directory.
  5. Back up the whd.conf file to a separate directory. 
  6. Open the whd.conf file in a text editor.
  7. In the file, locate PRIVILEGED_NETWORKS
  8. Add the Web Help Desk server IP address as a privileged network.
  9. Save your changes.
  10. Start Web Help Desk. 

 

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