Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Web Help Desk (WHD) > Web Help Desk is down with an email data object error

Web Help Desk is down with an email data object error

Updated December 28, 2017

Overview

This article describes how to resolve the issue where WHD is down and TRUNCATE EMAIL_DATA_OBJECT gives the following error message:

 The transaction log for database 'WHD' is full due to 'LOG_BACKUP'

Environment

  • WHD 12.2.3
  • Windows Server 2012

Cause

This issue occurs when the EMAIL_DATA_OBJECT size increases exponentially. This object stores reference data, such as rejected email. 

Resolution

Address the database issue

  1. Change Database Recovery model from Full to Simple.
  2. Shrink log files using SQL Studio.
    1. Right click WHD Database and select Tasks > Shrink > Files.
    2. Select the Log in File Type field.
    3. Click OK.
  3. Truncate EMAIL_DATA_OBJECT.

Control the growth of EMAIL_DATA_OBJECT

  1. Log in to the WHD Console as an Administrator.
  2. Go to Setup > E-Mail > Options.
  3. Under E-Mail Options, set the Delete E-Mail History Entries After setting to a shorter time period.
    delete-email-history.png 
  4. Click Save.

 

 

Last modified

Tags

Classifications

Public