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Home > Success Center > Web Help Desk (WHD) > Unable to log in to LDAP

Unable to log in to LDAP

Updated March 15, 2017

Overview

  • Unable to login to LDAP.
  • The WHD local account needs to be restored. 

Environment

  • WHD 12.x
  • PostgreSQL database

Cause 

The LDAP server is defunct.

Resolution

  1. Log in to the Web Help Desk server.
  2. Open the <WebHelpDesk> directory.
  3. Navigate to pgsql9 > pgAdmin III > docs > en_US and double-click index.htm.
  4. In the pgAdmin III guide under Using pgAdmin II, click Connect to server. 
  5. Follow the instructions to connect to the server using pgAdmin. 
  6. Open pgAdmin. 
  7. Click SQL.
  8. Use the following queries to disable LDAP authentication on the technician account.
    Replace ClientID=1 with the technician ID (as displayed in the TECH table):
     
    UPDATE TECH SET LDAP_CONNECTION_ID=NULL WHERE CLIENT_ID=1;
    UPDATE TECH SET USE_LDAP_AUTHENTICATION=NULL WHERE CLIENT_ID=1;
  9. Login to the WHD Web Console using a local account.

  10. Click Setup > Clients > AD / LDAP Connection.

  11. Click the appropriate connection in the Connection column.

  12. Update the LDAP settings as required, and then click Save. 

 

 

 

Last modified
12:54, 15 May 2017

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