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Home > Success Center > Web Help Desk (WHD) > LDAP not working and need to restore local login

LDAP not working and need to restore local login

Created by Maciej Klasa, last modified by Rodim Suarez on Mar 09, 2017

Views: 173 Votes: 0 Revisions: 4

Updated March 9, 2017

Overview

Unable to login to LDAP and will need to restore the WHD local account.

Environment

  • WHD 12.x
  • PostgreSQL database

Cause 

The LDAP server is defunct.

Resolution

  1. Open PgAdminIII from PostgreSQL folder in WHD
  2. Click Connect then provide connection details
  3. Click SQL.
  4. Use following queries to disable LDAP authentication on Technicians account. Replace ClientID=1 with Technicians ID (can be found in TECH table):
     
    UPDATE TECH SET LDAP_CONNECTION_ID=NULL WHERE CLIENT_ID=1;
    UPDATE TECH SET USE_LDAP_AUTHENTICATION=NULL WHERE CLIENT_ID=1;
  5. Login to the WHD Web Console using local account and update LDAP settings in Setup, Clients, LDAP Connection

 

 

 

Last modified
22:58, 8 Mar 2017

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