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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Web Help Desk stops collecting email after an SSL Certificate update

Web Help Desk stops collecting email after an SSL Certificate update

Overview

After you update the SSL certificate on a server running Microsoft® Exchange Server, Web Help Desk cannot retrieve incoming emails. 

Environment

All WHD versions

Cause

The Web Help Desk Java code does not recognize a Certificate Authority. As a result, Web Help Desk does not accept the certificate.

Resolution

Use Portecle to import the Certificate Authority Information (CRT) file to the Web Help Desk cacerts trust store. See the appropriate procedure below for your operating system.

Microsoft Windows

  1. Navigate to C:\Program Files\WebHelpDesk.
  2. Double-click Portecle.bat.
  3. Navigate to \bin\jre\lib\security and double-click cacerts
  4. Enter your password.
    The default password is changeit
  5. Click Tools > Import Trusted Certificates and locate the CRT file. 
  6. Enter an alias or name.
  7. Click File > Save Keystore.
  8. Restart Web Help Desk

Mac OS X and macOS

  1. Log in to the server with administrator privileges.
  2. Navigate to Applications > WebHelpDesk and double-click Portecle.
  3. Click File > Open Keystore File.
  4. Open Terminal and enter /usr/libexec/java_home.
  5. Enter your password.
    The default password is changeit.
  6. Click Tools > Import Trusted Certificates and locate the CRT file. 
  7. Enter an alias or name.
  8. Click File > Save Keystore
  9. Restart Web Help Desk.

Linux (Virtual Appliance)

Use the appliance terminal to import the certificate.

  1. Open a terminal window.
  2. Execute:
    echo -n | openssl s_client -connect <exchange_address> : <port> | sed -ne '/BEGIN CERTIFICATE-/,/-END CERTIFICATE-p' > /tmp/<cert_name>.crt
    where
    • <exchange_address> is the IP address of your Exchange server.
    • <port> is the the port number for HTTP communications with Microsoft Exchange Web Services (usually port 80).
    • <cert_name> is the file name of your Certificate Authority Information (CRT) file. 
  3. Execute:
    sudo /usr/local/webhelpdesk/bin/jre/bin/keytool -import -trustcacerts -keystore /usr/local/webhelpdesk/bin/jre/lib/security/cacerts -storepass <password> -noprompt -alias <cert_alias_name> -file /tmp/<cert_name>.crt
    where:
    • <password> is the cacerts password (the default password is changeit). 
    • <cert_name> is the CRT file name. 
  4. Restart Web Help Desk

 

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