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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Unable to log in to WHD after enabling SSO

Unable to log in to WHD after enabling SSO

Created by Maciej Klasa, last modified by PatriciaMarie.Esquejo on Mar 30, 2018

Views: 642 Votes: 2 Revisions: 4

June 14, 2017

Overview

Users are unable to log in to WHD after setting up Single Sign-On (SSO) and Internet Explorer does not indicate any errors except for a blank page. Other browsers show the ADFS page with an error.

Environment

  • WHD 12.3
  • Windows 2012
  • MS SQL 2008
  • Linux
  • PostgreSQL

Cause 

This issue occurs when SSO is incorrectly configured.

Resolution

 

For MS SQL 2008 in Windows Server 2012:

 

  1. Log in to the MS SQL server.
  2. Open MS SQL Management Studio.
  3. Run the following query:
    update PREFERENCE SET EXTERNAL_AUTH_PARAM_TYPE=0;
  4. Restart WHD using the Start menu shortcuts.

 

For PostgreSQL in Linux Environment:

 

To disable SSO in the database:

 

  1. Login to the PostgreSQL interface 
/usr/local/webhelpdesk/bin/pgsql/usr/pgsql-9.2/bin/psql -h 127.0.0.1 -p 20293 -U whd whd
  1. Run the following SQL query
UPDATE PREFERENCE SET EXTERNAL_AUTH_PARAM_TYPE=0; 

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

Suggested tags: SSO, ASDF, web console

 

Reason for Rework or Feedback from Technical Content Review: 

 

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