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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Unable to access WHD after applying new SSL certificate

Unable to access WHD after applying new SSL certificate

Updated June 12, 2018

Overview

This article shows one of the possible resolutions when encountering an issue of not being able to access WHD after applying a new SSL certificate in a Windows environment.

ERROR MESSAGE:  Connection refused.

 

Environment

  • All supported WHD versions
  • Windows Environment

Cause 

The file keystore.jks is not in the default location: C:\Program Files\WebHelpDesk\conf. Because the file is not in the expected location, WHD is unable to locate the SSL certificate.

Resolution

  1. Log into your WHD Server.
  2. Go to <WebHelpDesk>\conf
  3. Open the whd.conf file through Notepad using an Administrator account.
  4. Go to Keystore settings (for SSL connections) settings.
  5. Enter the correct location of keystore.jks for "KEYSTORE_FILE=" using the following format:
    KEYSTORE_FILE=E:/location_of_keystore/keystore.jks
  6. Save the whd.conf file.
  7. Restart Web Help Desk service.
  8. Access the WHD site again.

 

 

 

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