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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Unable to access FAQs after upgrading to WHD 12.2

Unable to access FAQs after upgrading to WHD 12.2

Issue

After you upgrade Web Help Desk to version 12.2, FAQs are unavailable and the following error message displays in the whd-spring.log file:

Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OPTION SQL_SELECT_LIMIT=DEFAULT' at line 1

Environment

  • Web Help Desk 12.2
  • MySQL™ database

Cause

The MySQL Java Database Connectivity (JDBC) driver does not support a MySQL database connected to Web Help Desk version 12.2.

Resolution

Download and apply the latest JDBC driver on your MySQL database. To ensure compliance with MySQL licensing restrictions, the MySQL JDBC driver is no longer bundled with the Web Help Desk. 

  1. Backup your existing JDBC driver from your extension directory.
    Windows:  \Program Files\WebHelpDesk\bin\jre\lib\ext
    Macintosh:  /Library/Java/Extensions
    Linux:  /usr/local/webhelpdesk/bin/jre/lib/ext 
  2. Open a web browser and navigate to the MySQL Download Connector/J site. 
  3. Download and apply the latest JDBC driver to the appropriate directory listed in step 1.
  4. Restart Web Help Desk. 
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