Submit a ticketCall us

AnnouncementsTHWACKcamp 2018 is here

2018 is the seventh year for THWACKcamp™, and once again we’ll be live October 17 – 18 with packed session tracks covering everything from network monitoring and management, to change control, application management, storage, cloud and DevOps, security, automation, virtualization, mapping, logging, and more.

Register for online sessions.

Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Unable to Use Single Sign On in Web Help Desk

Unable to Use Single Sign On in Web Help Desk

Table of contents
Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 2,348 Votes: 0 Revisions: 10

Issue:

Single Sign On (SSO) sources does not work in Web Help Desk (WHD) when using Apache. Reconfiguring WHD to use IIS is also unsuccessful.

Cause:

Web Help Desk (WHD) tries to authenticate users on the same port (8081) it uses for network communication.

Resolution:

Use Apache on port 80 to get the REMOTE_USER header to determine a logged-in client. This method authenticates the client without requiring a password. The header passes to Tomcat and WHD, running on port 8081.

To enable this type of SSO authentication, switch WHD's authentication method in its settings to authenticate users and create an LDAP connection to access a client list. Based on their user names matching the REMOTE_USER header, users in the Active Directory (AD) user list are automatically logged in from the WHD URL.

For configuration and other details, please refer to Web Help Desk Forums’ Troubleshooting  & Configuration: Single Sign On Setup

Last modified

Tags

Classifications

Public