Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > HTTP Error 502 displays when opening the WHD Console

HTTP Error 502 displays when opening the WHD Console

Overview

This article provides steps to resolve the following error when accessing the Web Help Desk Console.: 

HTTP Error 502 Bad Gateway

Environment

  • All WHD versions
  • Linux Environment

Cause 

Multiple Java Daemon instances are running on the Web Help Desk server.

Resolution

1. Stop the Web Help Desk Service. 
  #sudo service webhelpdesk stop

2. Check if there are multiple instances of Java Daemon running on the server. 
  #ps -ef | grep java

3. Stop all running Java instances.
   #kill -9 <Java PID> 

4. Start the Web Help Desk Service. 
  #sudo service webhelpdesk start 

 

 

Last modified

Tags

Classifications

Public