Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Error when sorting ticket history by time

Error when sorting ticket history by time

Table of contents

Issue

When you return to History after sorting the time in a ticket note, Web Help Desk generates the following error:

We're sorry, an unexpected error occurred:

java.lang.IllegalStateException: addOrderByAttributeOrdering: attempt to generate SQL for com.webobjects.eocontrol.EOSortOrdering  failed because attribute identified by key 'jobTimeFromTechNotes' was not reachable from from entity 'JobTicket'

Cause

The Web Help Desk remembers the last-applied sort settings, which are stored in the client.sort_prefs database column. When a client sorts the data by time, the history is not available, thereby generating an error. 

Workaround

Update the client.sort_prefs database column. 

To prevent data loss, back up the PostgreSQL database using the Web Help Desk Admin Console or a command line before you perform this procedure. See Best practices for database backup for additional information. 

  1. Log in to the Web Help Desk server as an administrator.
  2. Stop the Web Help Desk services.
  3. Execute the following SQL statement:
    update client set sort_prefs = null where client_id = X
  4. Start the Web Help Desk services
Last modified

Tags

Classifications

Public