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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Error displays when activating a WHD license

Error displays when activating a WHD license

Overview

When you activate a Web Help Desk license, the following error message displays: 

We're sorry, an unexpected error occurred:
java.lang.SecurityException: Could not open windows registry 
nodeSoftware\JavaSoft\Prefs\com\nec\jp\dianascope\prefs 
at root 0x80000002: Access denied

Environment

  • All WHD versions
  • Supported versions of Windows Servers

Cause 

The WebHelpDesk Service could not open the Windows Preferences (prefs) registry due to permission restrictions. The service should be running using the Local System Account to access the registry node: ..\HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs\com\solarwinds\licensing\gen2.

Resolution

  1. Start the Web Help Desk Service.
  2. Right-click Web Help Desk and select Properties > Log On.
  3. Change the Web Help Desk Service log on as:
    Local system account

 

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