Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Error after upgrading to WHD 11.2

Error after upgrading to WHD 11.2

Overview

When you upgrade Web Help Desk after an upgrade to v11x, the following error displays: 

java.lang.StackOverflowError

Environment

WHD version 11.0.x and 11.2.x 

Cause 

Incorrect CUSTOM_FIELD_DEFINITION table values in the Web Help Desk database.

 

Resolution

SolarWinds suggests upgrading Web Help Desk to the latest version. See the Upgrade Guide for procedures and an upgrade path.

To fix your current version, perform the following steps:

  1. Create a full backup of your Web Help Desk database, as the proceeding steps permanently updates your database.
  2. Open an SQL Query to the Web Help Desk database.
  3. Modify the CUSTOM_FIELD_DEFINITION table by executing the following SQL statements:
    UPDATE CUSTOM_FIELD_DEFINITION
    SET OLD_CUSTOM_FIELD_NUMBER=NULL
    ;
  4. Stop and then start Web Help Desk.

 

 

 

Last modified

Tags

Classifications

Public