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Home > Success Center > Web Help Desk (WHD) > WHD - Knowledgebase Articles > Asset Sync Error: ORA-01882 timezone region not found

Asset Sync Error: ORA-01882 timezone region not found

Updated July 16, 2018

Overview

When you attempt to sync assets from an Oracle database, the following error is returned:

ORA-00604: error occurred at recursive SQL level 1 ORA-01882: timezone region not found

Environment

  • All WHD Versions

Cause 

There has been a change in the way JDBC handles timezone differences between the client and database. The old behavior was that the JDBC would compute a GMT offset and continue when there was a mismatch between the client timezone and the database timezone. However, the new behavior is to try to use the timezone name/region defined by the client. If the database does not support that particular name/region, we now get an error.

Resolution

For OSX or Linux Servers

  1. Open the <webheldpesk>/conf/whd.conf file in a text editor.
  2. Add the following to the JAVA_OPTS section. Place the entire set of arguments between the pair of quotes, in the following format:
    JAVA_OPTS="-Doracle.jdbc.timezoneAsRegion=false"
  3. Stop Web Help Desk.
  4. Start Web Help Desk.

For Windows Servers

  1. Open the <WebHelpDesk>\bin\wrapper\conf\wrapper_template.conf file in a text editor.
  2. Add the following JVM arguments to the Java Additional Parameters section:
    wrapper.java.additional.xx=-Doracle.jdbc.timezoneAsRegion=false 
    where xx is the next corresponding number in the list of arguments
  3. Stop Web Help Desk using the Start Menu options (Right-click to Run as Admin).
  4. Start Web Help Desk using the Start Menu options (Right-click to Run as Admin).

 

 

 

 

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