Submit a ticketCall us

Get a crash course on Network Monitoring delivered right to your inbox
This free 7-day email course provides a primer to the philosophy, theory, and fundamental concepts involved in IT monitoring. Lessons will explain not only how to perform various monitoring tasks, but why and when you should use them. Sign up now.

Home > Success Center > Web Help Desk (WHD) > Java.lang.NullPointerException error when upgrading to 12.5.1

Java.lang.NullPointerException error when upgrading to 12.5.1

Updated July 25, 2017

Overview

The following error is displayed when upgrading to WHD v12.5.1:

java.lang.NullPointerException 
The following error is also found in the whd-spring.log file: 

[ApplicationManager-8] ERROR c.s.w.s.a.i.WhdApplicationManagerImpl - Failed to start WHD application. Reason: DB_INIT_FAILED
com.microsoft.sqlserver.jdbc.SQLServerException: Cannot find the object "dbo.JOB_TICKET" because it does not exist or you do not have permissions.

Environment

WHD 12.5.1

Cause 

The WHD database from the MS SQL Server is not using the default schema [dbo], causing the database upgrade to fail. 

Resolution

Run the following query to change the WHD database schema from the MS SQL Server to default [dbo]:

ALTER Schema dbo Transfer whd. <table name>

Examples:

ALTER Schema dbo Transfer whd. PLUGIN_PREFERENCE
ALTER Schema dbo Transfer whd. PREFERENCE
ALTER Schema dbo Transfer whd. PRIORITY_TYPE
 

 

Last modified
18:44, 24 Jul 2017

Tags

Classifications

Public