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HTTP Error 502 displays when opening the WHD Console

Overview

This article provides steps to resolve the following error when accessing the Web Help Desk Console.: 

HTTP Error 502 Bad Gateway

Environment

  • All WHD versions
  • Linux Environment

Cause 

Multiple Java Daemon instances are running on the Web Help Desk server.

Resolution

1. Stop the Web Help Desk Service. 
  #sudo service webhelpdesk stop

2. Check if there are multiple instances of Java Daemon running on the server. 
  #ps -ef | grep java

3. Stop all running Java instances.
   #kill -9 <Java PID> 

4. Start the Web Help Desk Service. 
  #sudo service webhelpdesk start 

 

 

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