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Home > Success Center > Web Help Desk (WHD) > Exception error in tickets for multiple locations when history is sorted by time

Exception error in tickets for multiple locations when history is sorted by time

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Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 1,031 Votes: 0 Revisions: 10

Issue:

The following error/exception appears for client logins if they try to re-access the History after sorting the Time in one of the ticket notes.

kb 5445.png
We're sorry, an unexpected error occurred: 
java.lang.IllegalStateException: addOrderByAttributeOrdering: attempt to generate SQL for com.webobjects.eocontrol.EOSortOrdering  failed because attribute identified by key 'jobTimeFromTechNotes' was not reachable from from entity 'JobTicket'

Cause:

Sort preferences are stored in the client.sort_prefs column of the database and it remembers the last applied sort settings. Therefore, when a client sorts the data by time, the history is not available and the error occurs.

Workaround:

Before doing any work on your database please make sure that you have a current backup, as this will make a permanent change to your database.

Note: To backup the database, refer to How to Backup/Restore the WHD Database

1. Stop WHD Services - Start/Stop WHD Services.

2. Open the WHD database. 

3. Execute the SQL statement:

update client set sort_prefs = null where client_id = X

4. Start WHD Services.

Last modified
04:40, 23 Jun 2016

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