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Home > Success Center > Web Help Desk (WHD) > Error encountered when searching Web Help Desk with a SQL Server database

Error encountered when searching Web Help Desk with a SQL Server database

Updated March 11th, 2016

Overview

Running ticket queries on Web Help Desk (WHD) with a SQL Server database produces errors and freezes the system.

Environment

Web Help Desk

Cause

WHD is configured to fetch and display too many tickets in response to queries. This situation is most likely to occur when searching using LIKE as a search parameter, which uses wildcard characters and often returns more responses than the system is set up to handle.

Steps

Update to the latest WHD hotfix, available through the SolarWinds Customer Portal.

After applying the hotfix, configure WHD and SQL Server to use a full text search, which searches for tickets using Contains, rather than Like:

  1. Enable full text search in the Web Help Desk application by adding the parameter: -DWHDSqlServerFulltextSearchEnabled=true to file <webhelpdesk>\bin\wrapper\conf\wrapper_template.conf</webhelpdesk> for Windows installations or <webhelpdesk>\conf\whd.conf </webhelpdesk>for OS X and Linux installations.
  2. Enable full text search in the SQL Server database, using the instructions in the article, Adding SQL Full-Text Search to an existing SQL Server (© 2017 CBS Interactive, available at http://www.techrepublic.com/, obtained on February 17th, 2017.)
  3. Create full text indexes for database tables by right-clicking on individual table names in the SQL Server Management Studio and selecting Full-Text Index > Define Full-Text index. A wizard appears, prompting you to select columns to include in the index.

 

For additional information, see the following SQL Server 2012 documentation:

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

Last modified
16:44, 17 Feb 2017

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