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Home > Success Center > Web Help Desk (WHD) > Error displays after upgrading Web Help Desk

Error displays after upgrading Web Help Desk

Issue

After you upgrade Web Help Desk from an older version (for example, from 11.2.0 to 12.0), an error displays, as shown below. 

exception error

If you click Continue at the top of the exception error, nothing happens. If you open a Web Help Desk instance in another Web Browser, the error disappears.

Cause

Web Help Desk is out of memory and could not establish a database connection. This issue causes Web Help Desk to become unresponsive. 

Resolution

Increase the JVM memory.

Web Help Desk requires additional max heap memory than the JVM memory default. After you enable the JVM, increase the MAXIMUM_MEMORY value in the whd.conf file and restart Web Help Desk.

  1. Determine the appropriate amount of memory for your deployment using the following formula:
    (Average number of concurrent techs x 150) + (Average number of concurrent users x 25) = MAXIMUM_MEMORY value
    For example, If the average number of concurrent techs is 10 and the average number of concurrent users is 50, the recommended MAXIMUM_ MEMORY value is 2750 (which is 2.75 GB): (10 x 150 = 1500) + (50 x 25 = 1250) = 2750
    The MAXIMUM_MEMORY value should not be greater than the total memory in the Web Help Desk server.
  2. Update the whd.conf file for your operating system.

Microsoft Windows

  1. Log in to the Web Help Desk server as an administrator.
  2. Stop Web Help Desk.
  3. Navigate to the Web Help Desk directory located at:
    C:\Program Files\WebHelpDesk\
  4. Open the \conf directory.
  5. Open the whd.conf file in a text editor (such as Notepad).
  6. In the whd.conf file, locate the MAXIMUM_MEMORY parameter.
  7. Change the parameter value to the value you calculated in an earlier step.
  8. Save and close the file.
  9. Restart Web Help Desk.
    1. In the WebHelpDesk directory, right-click whd_stop.bat and select Run as Administrator.
    2. After the command prompt window closes, right-click whd_ start.bat and select Run as Administrator.

Linux

  1. Stop Web Help Desk.
  2. Open a terminal window.
  3. Change the directory to the Web Help Desk /conf directory.
    Type:
    cd /usr/local/webhelpdesk/conf
  4. Open the whd.conf file.
    Type:
    sudo vi whd.conf
  5. Change the maximum JVM to the appropriate value.
    Execute:
    :%s/MAXIMUM_MEMORY=512/MAXIMUM_MEMORY=[memory in MB]/ :wq
    For example, if you want to change the value to 2750 MB, type:
    :%s/MAXIMUM_MEMORY=512/MAXIMUM_MEMORY=2750/ :wq
  6. Save and close the file.
  7. Restart Web Help Desk.
    1. In the terminal window, execute:
      sudo service webhelpdesk stop
    2. In the terminal window, execute:
      sudo service webhelpdesk start

 

Last modified
16:14, 30 Jun 2017

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