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Home > Success Center > Web Help Desk (WHD) > Error: Unable to connect to database

Error: Unable to connect to database

Overview

The following error displays in the Web Help Desk Console:

Unable to connect to database.

Environment

All Web Help Desk versions

Cause

The MySQL Java Database Connector (JDBC) driver is not installed on the Web Help Desk Server. To ensure compliance with MySQL licensing restrictions, the MySQL JDBC driver is not bundled with Web Help Desk.

Resolution

If you are connecting to a MySQL database (used for some asset discovery connections), download and install the MySQL JDBC driver from the MySQL website.

  1. Log in to the Web Help Desk server as an administrator.
  2. Stop the Web Help Desk service
  3. Open a web browser and navigate to the MySQL website.
  4. Locate and download the Platform Independent driver. 
  5. Unzip the file to a local directory.
  6. Copy the JDBC driver to the appropriate directory on your server.
    Operating System Path
    Microsoft Windows \Program Files\WebHelpDesk\bin\jre\lib\ext
    Apple OS X and macOS /Library/Java/Extensions
    Linux /usr/local/webhelpdesk/bin/jre/lib/ext
  7.  Restart the Web Help Desk service
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