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Home > Success Center > VoIP & Network Quality Manager (VNQM) > Troubleshooting Failed AXL Credentials

Troubleshooting Failed AXL Credentials

Updated March 11th, 2016

Overview

Troubleshooting Failed AXL Credentials

Environment

VoIP

Cause

  • Incorrect AXL credentials
  • Disabled AXL API
  • Connectivity issues between the Cisco CallManager and VoIP and Network Quality Manager
  • Deprecated SHA-1 Certificates on Windows operating systems

Resolution

To troubleshoot AXL credentials:

  1. Open a browser on your VoIP and Network Quality Manager server.
  2. Enter https://<ip address>:8443/axl/ in the address bar where <ip address> is the IP address of the call manager you are testing.
  3. If you receive a response similar the following, confirm that you entered the correct AXL credentials in VoIP and Network Quality Manager: "Cisco CallManager: AXL Web Service The AXL Web Service is working and accepting requests. Use HTTP POST to send a request."
  4. If you receive no response, do one of the following:
    • Ensure that the AXL API is enabled on the call manager
    • Ensure that you can connect to the call manager through your firewalls 
       

Deprecated SHA-1 Certificates on Windows operating systems:

Windows blocks SHA-1 signed TLS certificates effective January 1, 2017. (© 2017 Microsoft, available at https://blogs.windows.com, obtained on March 24th, 2017.) You can find additional details about Windows Enforcement of SHA1 Certificates here (© 2017 Microsoft, available at https://social.technet.microsoft.com, obtained on March 24th, 2017.).

  • To solve this issue, it's highly recommended to update SHA certificates on CallManager. 
  • SHA-1 deprecation is pushed out through Windows Update so as a temporary workaround, you can remove the relevant Windows Updates. Please keep in mind, this is a temporary solution only.
    • Windows 10: KB3163912
    • Windows 10 Version 1511: KB3172985
    • Windows 7 and Server 2008 R2: KB3170106 and KB3172605
    • Windows 8.1 and Server 2012 R2: KB3170106 and KB3172614

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

Last modified
12:59, 24 Mar 2017

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