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Home > Success Center > VoIP & Network Quality Manager (VNQM) > Null entries found in the VoipEngines table

Null entries found in the VoipEngines table

Updated: October 9, 2017

Overview

Incorrect entries were found in the [dbo].[VoipEngines] table. Also, the timestamp displayed in the keepalive column of the [dbo].[VoipEngines] table shows the SolarWinds VNQM business layer started up.

Environment

  • VNQM all versions

Cause 

Services may have started on an old decommissioned polling engine. When services are not disabled and only in a stopped state, the old poller may start the Orion services.

When this occurs, an entry should not exist in the [dbo].[Engines] table. If an entry is present, you would need to run the Configuration Wizard ticking database for the software to actually update that table. You will then start to get NULL entries in [dbo].[VoipEngines] table as the VNQM business layer is trying to find the engine in the engines table, which no longer exists.

 

Resolution

  1. Disable or uninstall the SolarWinds services on the old poller.
  2. Open the Database Manager and execute:
    SELECT TOP 1000 * FROM [dbo].[VoipEngines]
  3. Locate the VoipEngineID entries. 
  4. Execute:
    DELETE FROM [dbo].[VoipEngines]
    where VoipEngineID = the ID you want to remove.
  5. Replace VoipEngineID with the ID you want to remove.

 

 

 

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