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Home > Success Center > Virtualization Manager (VMAN) > VMan integrated with NPM shows Data Not Available

VMan integrated with NPM shows Data Not Available

Created by Roger Lofamia, last modified by Harry Griffiths on Nov 16, 2017

Views: 211 Votes: 1 Revisions: 5

Overview

The NPM virtualization summary or VM node details are not showing any data on VMan resources and displays the following message:

Data Not Available

Environment

  • NPM integrated with VMan Appliance

Cause 

This can occur when VMan is unable to resolve the hostname to IP address of the Orion server making VMan unable to send data to the Orion server.

Resolution

Warning: Create a back up or take a snapshot of the appliance before making any changes, in case you need to roll back later.

  1. SSH to VMan appliance using PuTTy or a similar application.
  2. Log in with the default admin/admin credentials or the VMan Web console admin user account.
  3. Change the admin user privilege to root by using the following command: sudo su
  4. Edit the host file using the following command: vi /etc/hosts
  5. Add the IP address and hostname and IP address and FQDN of the Orion NPM server.
  6. Save the changes using the following command: :wq!
  7. Reboot the VMan server.
  8. Reintegrate VMan with the Orion server.

Note:

Check VMAN logs to make sure information is being sent to the Orion server without error. Also make sure its trying to send to correct IP/Hostname of the Orion server via the logs.

 

You can view VMan logs from the VMAN webconsole:

https://ipaddressofvman:5480

Login

Under the Solarwinds Mgmt Tab there is a button that says "View Recent Log Activity" where you can view the logs.

More logs can be found via "Bundle Logs" button at the bottom of the Solarwinds Mgmt Tab which will zip all the logs up for you to view.

 

 

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