Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

 

 

 

Home > Success Center > Virtualization Manager (VMAN) > VMAN tools resource does not load after integration

VMAN tools resource does not load after integration

Created by Harry Griffiths, last modified by MindTouch on Jun 23, 2016

Views: 837 Votes: 1 Revisions: 6

Overview

Depending on your environment, you may have enabled IVIM-VMAN integration and notice that the virtualization tools resource still does not display on the virtualization summary view after several minutes and still shows:

 

This resource relies on data from the Virtualization Manager product. 
If you haven't already done so, then configure credentials, data sources, 
and collection schedules in the VMan console. 
It may take several minutes before data is available here, depending on the size 
of your environment.

 

Unusual Symptoms:

  • Upon checking Solarwinds Information Service V3 (SWIS V3) and Orion Web logs, no visible issues can be seen.
  • Upon checking virtual machine tables, data is being received fine and there looks to be no other issue between IVIM and VMAN integration.

Environment

IVIM and VMAN Integration - all versions

Cause 

There was an issue with the identity mapping portion during the original integration, possibly due to issues in the pub\sub.

This issue can actually occur due to problems delivering notifications using Solarwinds Information Service V3.

To verify that this issue matches this article, please run this query in Database Manager:

  1. Go to Volume:\Program Files (x86)\SolarWinds\Orion\DatabaseManager.exe.
  2. Right Click and open it as administrator.
  3. Click Add Default Server.
  4. Expand your Orion Database.
  5. Right click and click New Query.
  6. Copy and paste the below query
SELECT TOP 1000 * FROM [dbo].[Subscriptions]
ORDER BY FailedDeliveryAttempts DESC

Resolution

  1. Backup the database.
  2. Shut down all SolarWinds services on every polling engine and additional web server.
  3. Open Database Manager or SQL Management Studio and execute the following SQL queries against the Orion database.
    If using Database Manager
    a. Go to Volume:\Program Files (x86)\SolarWinds\Orion\DatabaseManager.exe.
    b. Right Click and open it as administrator.
    c. Click Add Default Server.
    d. Expand your Orion Database.
    e. Right click and click New Query.
    f. Copy and paste the below query:
DELETE FROM dbo.PendingNotifications
DELETE FROM dbo.Subscriptions
DELETE FROM dbo.SubscriptionTags

Next, you should fully disable then enable the VMAN integration to force the remapping of identities.

 

Last modified
04:22, 23 Jun 2016

Tags

Classifications

Public