Submit a ticketCall us

WebinarUpcoming Webinar: Know What’s Changed – with NEW Server Configuration Monitor

Change management in IT is critical. But, even with a good change management process, changes are too often not correctly tracked, if at all. The configuration of your servers and applications is a key factor in their performance, availability, and security. Many incidents can be tracked back to an authorized (and sometimes unauthorized) configuration change, whether to a system file, configuration file, or Windows® Registry entry. Join SolarWinds VP of product management Brandon Shopp to discover how the new SolarWinds® Server Configuration Monitor is designed to help you.

Register now.

Home > Success Center > Virtualization Manager (VMAN) > VMAN - Knowledgebase Articles > No VMs and Datastore data on Orion Virutalization Summary

No VMs and Datastore data on Orion Virutalization Summary

Updated September 1, 2016

Overview

VMAN is unable to send data to the Orion server. The Orion Virtualization summary is not showing any VMs or Datastore data.

Environment

  • NPM 12
  • NPM 11.5.x
  • VMAN 6.x (version must be compatible with NPM)

Cause 

This happens when the Orion server has two NICs and the Orion server is using the incorrect IP address from one of the NICs.

VMAN master logs show that VMAN is able to send the data to the Orion server through the incorrect IP address successfully. This is because the incorrect IP address is pingable and ports 17777 and 17778 are open.

However, upon further checking. It was found that the Orion server has two NICs and VMAN is suppose to send the data on NIC 1 (with the correct IP address) instead on NIC 2 (with the incorrect IP address).

So the issue is with the incorrect IP address that is assigned to the Orion primary module engine. Running the Configuration Wizard does not correct the issue and it was found that NIC 1 is the primary NIC.

Resolution

Auto metric is enabled on the NICs and it seems that this is causing the Configuration Wizard to use NIC 2 instead of NIC 1.

The solution is to set the metric to manual and assign the value '1' (no quotes) to the NIC (on this case NIC1) that has the correct IP address. The '1' value will make the NIC 1 the priority NIC.

This solution most of the time is unacceptable due to strict compliance. You may try to change the IP address on the Orion database manually but when you run the Configuration Wizard it will just revert to the previous setting.

 

Workaround:

Disable NIC 2 then run Configuration Wizard. This will force Configuration Wizard to use the NIC 1 IP address.

Reintegrate VMAN to the Orion server and run VMAN Synchronization Wizard.

 

Last modified

Tags

Classifications

Public