Submit a ticketCall us

WebinarUpcoming Webinar: How Help Desk and Remote Support Pays for Itself

Learn how help desk software can simplify ticketing management, allow you to track hardware and software assets, and accelerate the speed of IT support and service delivery. Gain insights on how remote support tools allow your IT team to maximize their efficiency and ticket resolution by expediting desktop troubleshooting, ultimately helping keep end-users happy and productive.

Register here.

Home > Success Center > Virtualization Manager (VMAN) > VMAN - Knowledgebase Articles > Manage Alerts page is empty after upgrade

Manage Alerts page is empty after upgrade

Updated March 14, 2017

Overview

Unable to view the Manage Alerts page in the Orion Web Console or the page just returns as empty after upgrading VMan to v7.0. 

 

The logs are showing the following errors:

2016-11-03 08:59:37,918 [154] (1460) ERROR NewAlertingService - (null)  Failed to retrieve alerts.
System.InvalidCastException: Cannot cast DBNull.Value to type 'System.Int32'. Please use a nullable type.
at System.Data.DataRowExtensions.UnboxT`1.ValueField(Object value)

Environment

Orion VIM 7.0

Cause 

There are action assignments for non existing actions.

Resolution

Take a full backup of your Orion database, and then run following query

DELETE FROM ActionsAssignments WHERE ActionID NOT IN (SELECT ActionID FROM Actions);

This will delete obsolete action assignments.

Try opening Manage Alerts page after that.

 

Last modified

Tags

Classifications

Public