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Home > Success Center > User Device Tracker (UDT) > UDT 3.3.1 not updating layer 2 data

UDT 3.3.1 not updating layer 2 data

Updated June 18th, 2018

Overview

UDT is not updating current layer 2 connection information.

  • Layer 2 data may be missing (the MAC address is not seen on the port)
  • Layer 2 data may be outdated (the MAC address might appear on a port that it is no longer connected to)

The following log file includes the error message below:

C:\ProgramData\SolarWinds\Collector\Logs\Plugins\SolarWinds.UDT.Layer2PollingPlan.log

ERROR SolarWinds.UDT.Services.ResultProcessingServices.Layer2ResultProcessorService - Reseting static connection. Exception at updateNodeData-layer2, Exception: System.Transactions.TransactionManagerCommunicationException: Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administrative tool. ---> System.Runtime.InteropServices.COMException: The transaction manager has disabled its support for remote/network transactions. (Exception from HRESULT: 0x8004D024)

Environment

  • UDT 3.3.1 with a remote SQL database (this does not affect instances where SQL is installed on the UDT server)

Cause 

UDT is unable to open a new connection to write to the database.

Resolution

Download and apply UDT 3.3.1 Hot Fix 1. This can be downloaded from your Customer Portal.

 

 

 

 

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