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Home > Success Center > User Device Tracker (UDT) > UDT - Knowledgebase Articles > UDT Whitelist rule changes to different type after submission or reboot

UDT Whitelist rule changes to different type after submission or reboot

Updated: 11/3/17

Overview

This article describes a known issue that can happen in UDT when a Whitelist rule is created as one Custom Type, and is changed to a different Type at a later date. The Taret reverts to the original after submission or reboot.

 

Example:
The IP Address rule TestRule is created:

2017-11-02_1628.png

 

This shows up as the following in Manage Whitelist:

2017-11-02_1630_001.png

 

Now, edit the rule again and change it to a MAC address rule with an inserted MAC like so:

2017-11-02_1631.png

 

Once  the rule is saved and you go to Manage rules, you'll see that it still shows the Target as it did before:

2017-11-02_1632.png

You can see that the date has changed, but the Target remains as IPAddress. If you then edit the rule, you will see the following:

2017-11-02_1633.png

Environment

  • UDT 3.2.4 and higher

Cause 

This is a known bug within UDT. The setting is retained until the rule is removed.

 

Resolution

To resolve the issue, you need to delete the original rule and create a replacement rule with the new type.

 

 

 

 

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