Submit a ticketCall us

WebinarWebinar: A checklist for planning your Network Performance Monitor (NPM) upgrade

Are you ready for your next upgrade? To help you plan smoothly, join this webcast to learn more about, SolarWinds® Orion® Installer, SolarWinds Upgrade Advisor, Upgrades Guides, Training Videos, and other resources available. We’ll share key upgrade planning considerations, lessons learned from customers with practical advice from SolarWinds Product Experts. We’ll also give practical tips to identify the estimated time needed and resources, how to prepare the business and IT staff for changes, ways to plan for required system changes, and more.

Register now.

Home > Success Center > User Device Tracker (UDT) > UDT - Knowledgebase Articles > All nodes and ports are being automatically added to UDT

All nodes and ports are being automatically added to UDT

Created by Matthew Lamb, last modified by Nigel on Jul 05, 2018

Views: 975 Votes: 3 Revisions: 15

Updated: 23rd Oct 2017

Overview

This article covers an issue that can occur when upgrading UDT to version 3.3. In this issue, any node that is not already within UDT  is automatically added. This includes all the nodes ports if they are SNMP, and even includes WMI based nodes that are not capable of being polled by UDT for port and endpoint information.

This problem can occur with existing nodes and any nodes added in after this point.

Attempts to remove the nodes result in the nodes being added back into UDT shortly afterwards.

You may also see files filling up in the following folder. It is safe to clear these out until a fix is in place.

Environment

  • UDT 3.3

 

Cause 

Incorrect handling of polling jobs on nodes on startup. It starts the jobs on all listed nodeids, causing them to be added into UDT in the process.

 

Resolution

This issue was resolved with UDT 3.3 HotFix 1.

Once the hotfix is applied this issue should not occur.
However, if you were using UDT without HotFix 1 for some time, additional steps may be needed:

  • Check your UDT configuration as it is possible you may need to apply some further steps if Hotfix 1 was not applied at the time of UDT 3.3 deployment. 

 

To resolve the issue:

  1. Apply UDT 3.3 HF1, by running the Orion Installer or download it from https://customerportal.solarwinds.com/HotFixes# (Install HotFix on all servers [primary poller, APEs, AWSs])
  2. From the Orion web console go to the Port Management (../Orion/UDT/Ports/Default.aspx) page.
  3. Chose Show: Nodes and Filter to: UDT Monitored Nodes.
  4. Check nodes you do not need to monitor with UDT.
  5. Click Delete.
  6. Make sure that only Delete node and data from UDT only is checked and click Delete button.
  7. Repeat steps 4-6 for all node pages, if required.

Steps 2-7 should not be needed for customers who installed UDT 3.3 after  UDT HotFix 1 was released, as the hotfix now auto-installs with UDT 3.3.

If, however,  you do require the hotfix to correct the issue, we recommend the following additional steps:

  1. Stop All Orion services (on all pollers if there are multiple pollers)
  2. Execute these two SQL queries in the following order:
    • L2\L3 polling isn't needed for Windows devices, as such, run the following SQL query in database Manager:
      delete from udt_nodecapability where nodeid in (select nodeid from nodesdata where objectsubtype = 'WMI') and Capability != 8
    • Next to clean up the UDT Tables after running above query, to remove unwanted UDT jobs:
      DELETE FROM udt_job WHERE nodeid NOT IN (SELECT nodeid FROM udt_nodecapability)
  3. Clean up Collector 'sdf' data and JobEngine 'sdf' data on all pollers.
    • JobEngine data: C:\ProgramData\Solarwinds\JobEngine.v2\Data\
    • Collector data: C:\ProgramData\SolarWinds\Collector\Data

To clean up data files:

  1. Stop all SolarWinds services (on all pollers if there are multiple pollers).
  2. Navigate to 'Data' folders above.
  3. Prepare a backup copy of the 'JobEngine35.sdf' or 'PollingController.sdf' file.
  4. Delete 'JobEngine35.sdf' or 'PollingController.sdf'.
  5. Copy 'JobEngine35 - Blank.sdf' or 'PollingController-Blank.sdf' to the same folder and rename it to 'JobEngine35.sdf' or 'PollingController.sdf'.
  6. Remove the "Read-only" attribute from that files.
  7. Start all SolarWinds services.
 

 

Last modified

Tags

Classifications

Public