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Home > Success Center > User Device Tracker (UDT) > Authorization Error - User does not have rights to requested MIBs

Authorization Error - User does not have rights to requested MIBs

Updated June 10th, 2016

Overview

Customer is unable to see VLAN information from his devices.

Environment

UDT 3.x

Cause 

Target device does not have the correct permissions set.

 

All the IDF switches display PC and VoIP devices attached to them. After working with Cisco TAC and Solarwinds Support together, we found that the IDF switches did not display UDT information due to incorrect SNMP permissions. Though the SNMP ACL lines were configured, the SNMP group assigned to the SNMP user was wrong. As an example, as shown below:
 
SNMP user 'USER1' was assigned an SNMP group “solar”.
 

Where, the SNMP group “GROUP1” has permissions to access all VLANs. But, the SNMP user “USER1” was assigned to use the SNMP group “GROUP2”, which had no permissions to the VLANs.  Need to recreate user "USER1" to be apart of "GROUP1", the group that has permissions to access the VLANs.  OR simply configure UDT to use an already existing user that has permission to poll those VLANs via SNMP.

Resolution

Update the permission on the target device following this sample:


config t
no snmp-server user dconti solar v3
snmp-server user dconti v3-RO v3 auth sha <password> priv aes 128 <password>
snmp-server group v3-RO v3 priv context vlan- match prefix access 50
no snmp-server
snmp-server group v3-RO v3 priv context vlan- match prefix access 50
exit
wr

 

Last modified
09:22, 1 Feb 2017

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