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Home > Success Center > Storage Resource Monitor (SRM) > SRM - Knowledgebase Articles > Cannot enable integration with STM

Cannot enable integration with STM

Updated March 13, 2017

Overview

When enabling STM integration, you get the following error:

Unable to connect to Storage Profiler. Make sure the connecting Storage Profiler is at least v6.0 or newer and the required port is opened in firewalls.

 

The firewall is open. Software version is correct. In the logs there is an error:

23 Aug 2016 08:06:32 [ERROR] - Error sending data:
org.mortbay.jetty.EofException
Caused by: java.net.SocketException: Software caused connection abort: socket write error

Environment

  • SRM 6.3
  • STM 6.x

Cause 

Incorrect configuration of Tomcat on STM side.

Resolution

  1. In the STM server, go to STM install folder \conf (usually in c:\Program Files\SolarWinds\Storage Manager Server\conf).
  2. Open the server.xml file for editing (Notepad has to be opened as administrator). It is advised to take a backup of that file before any changes are made.
  3. Locate the connector element for port 8443 (not the commented out section containing string: <Connector port="8443").
  4. Remove one constant TLS_DHE_RSA_WITH_AES_128_CBC_SHAfrom the ciphers attribute. Do not remove TLS_DHE_DSS_WITH_AES_128_CBC_SHA.
  5. Make sure that the sslEnabledProtocols attribute is set to TLSv1.
  6. Save the server.xml file.
  7. Restart STM’s web server service.
  8. Open SRM and try to integrate with STM.

 

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