Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Storage Resource Monitor (SRM) > Cannot install SRM polling engine due to compatibility errors

Cannot install SRM polling engine due to compatibility errors

Updated March 15, 2017

Overview

Cannot install standalone SRM polling engine on a server without an additional polling engine. During installation, you get the following error:

The version of Orion Core installed on your primary Orion server is never than the version of Orion Core that you are trying to install on your additional server.

As for this case, SRM 6.3 is installed on the main poller and is attempting to install 6.3 on the additional polling engine.

Environment

  • SRM 6.3.0
  • NPM 12.0.1
  • SAM 6.2.4
  • Orion Platform 2016.2.100

Cause 

Core has been upgraded on the main poller beyond 2016.1. SRM 6.3 was shipped with Core 2016.1. When ran on the main server, the installer skipped Core installation as it was already on a later version (one of the products upgraded Core to 2016.2). However, on the additional poller Core was not present so the installer tried to install 2016.1.

Resolution

  1. Go to C:\ProgramData\Solarwinds\Installers on the main Orion server and copy the CoreInstaller.msi file.
  2. Transfer the copied file to the additional poller server (C:\ProgramData\Solarwinds\Installers). Create the folder if it does not exist.
  3. Run the CoreInstaller.msi and install Core using the CoreInstaller.msi ORIONINSTALLATIONTYPE=POLLER command.
  4. Rerun the SRM 6.3 installer.

 

Last modified
17:17, 14 Mar 2017

Tags

Classifications

Public