Submit a ticketCall us

Announcing NPM 12.2
With NPM 12.2 you can monitor your Cisco ASA firewalls, to monitor VPN tunnels for basic visibility and troubleshooting tunnels. NPM 12.2 also uses the SolarWinds Orion Installer so you can easily install and upgrade one or more Orion Platform products simultaneously.
See new features and improvements.

Home > Success Center > Storage Resource Monitor (SRM) > Assign TLS enabled SMI-S arrays to a JRE upgraded agent

Assign TLS enabled SMI-S arrays to a JRE upgraded agent

Overview

Secure Socket Layer (SSL) is disabled due to security vulnerability issues and Transport Layer Security (TLS) is enabled by default in the following storage array providers:

  • IBM SVC, V7000 SMI-S provider (from firmware 7.4.x.x)
  • Hitachi Data Systems (HDS) (from firmware 70-06-25-00)

Environment

All SRM versions

Cause

Storage Manager is using Java Runtime Environment (JRE) 1.6 which does not support TLS protocol version 1.1 or later. As a result, STM is failing to connect the provider with the TLS configuration.

Resolution

Do the following steps to avoid this issue:
1. Identify which Storage Manager agents are to be upgraded to the latest JRE version.
2. See the Storage Manager Administrator Guide on how to upgrade JRE 1.8 in the Storage Manager agent host.
3. Configure or reassign the storage array with the TLS enabled provider to the Storage Manager agent with an upgraded JRE version.

Last modified
17:21, 25 Nov 2015

Tags

Classifications

Public