Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Server & Application Monitor (SAM) > UseProxy Setting for HTTP Form Login Not Functioning in SAM

UseProxy Setting for HTTP Form Login Not Functioning in SAM

Updated October 25, 2017

Overview

The article details a bug in the UseProxy settings for HTTP Form Login. After configuring the HTTP Form Login and setting UseProxy to false, the proxy continues to be used.

 

Environment

  • SAM v6.4

 

Cause 

The user configured WPAD (Web Proxy Auto Discovery) and UseProxy is set to false, but SAM continues to use the proxy. If UseProxy is set to false, and continues to be used by SAM, explicitly disable the proxy.

 

Resolution

If UseProxy is set to false and continues to be used by SAM, explicitly disable the proxy.

  1. Fix only the HTTP Form Login
    Do not change proxy attributes for components. Introduce a toggle in APM.Probes App.config to "Forbid system proxy usage when the component is set to 'Do not use proxy' ":
    1. ON means we explicitly disable proxy.
    2. OFF (default) means we do not use proxy defined on the component level, but allow a system proxy to be used, if configured.
  2. Report a bug for other components using "Do not use proxy".
  3. Test the resolution through regression and manual testing.
 

 

Last modified

Tags

Classifications

Public